В ряду из десяти клеток правее Робота некоторые клетки закрашены. Последняя закрашенная клетка может примыкать к стене.

В ряду из десяти клеток правее Робота некоторые клетки закрашены. Последняя закрашенная клетка может примыкать к стене. Составьте алгоритм, который закрашивает клетки выше и ниже каждой закрашенной клетки. Проверьте работу алгоритма в следующих случаях:

Ряд из 10 клеток

Ответ

использовать Робот
алг
нач
нц 10 раз
вправо
если клетка закрашена
то
вверх; закрасить
вниз; вниз; закрасить
вверх
все
кц
кон

Опубликовано: 14.01.2019 Обновлено: 14.01.2019
Поделись с друзьями

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

14 + десять =