Составьте алгоритмы, под управлением которых Робот за­красит указанные клетки

Составьте алгоритмы, под управлением которых Робот за­красит указанные клетки. При необходимости используйте вспомогательный алгоритм.

Алгоритм угол для робота

Ответ

Решение этой задачи можно оформить с помощью вспомогательного алгоритма угол.

а)

использовать Робот
алг
нач
угол
вниз; вниз
вправо; вправо
угол
вниз; вниз; вниз
вправо
угол
кон
алг угол
нач
нц 5 раз
закрасить; вправо
кц
нц 5 раз
влево
кц
нц 4 раз
вниз; закрасить
кц
вниз
нц 5 раз
вверх
кц
кон

Для получения рисунков б) и в) нужно внести изменения в основной алгоритм.

б)

нач
нц 3 раз
угол
вниз; вправо
кц
кон

в)

нач
нц 3 раз
угол
вниз; вправо; вправо
кц
кон

Опубликовано: 14.01.2019 Обновлено: 14.01.2019
Поделись с друзьями

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

4 × 1 =