Решение 20.1 задания ОГЭ 2018 по информатике из демоверсии

Решение 20.1 задания ОГЭ 2018 по информатике из демонстрационного варианта. Проверяемые элементы содержания: Умение написать короткий алгоритм в среде формального исполнителя.

На бесконечном поле есть горизонтальная и вертикальная стены. Левый конец горизонтальной стены соединён с нижним концом вертикальной стены. Длины стен неизвестны. В вертикальной стене есть ровно один проход, точное место прохода и его ширина неизвестны. Робот находится в клетке, расположенной непосредственно над горизонтальной стеной у её правого конца.

На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

Решение 20.1 задания ОГЭ 2018 по информатике из демоверсии

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно левее и правее вертикальной стены. Проход должен остаться незакрашенным. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

Решение 20.1 задания ОГЭ 2018 по информатике из демоверсии 2

При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным.

Алгоритм должен решать задачу для любого допустимого расположения стен и любого расположения и размера прохода внутри стены.

Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе.

Сохраните алгоритм в текстовом файле. Название файла и каталог для сохранения Вам сообщат организаторы экзамена.

Решение 20.1 задания ОГЭ 2018 по информатике

Команды исполнителя будем записывать жирным шрифтом, а комментарии – курсивом. Начало комментария будем обозначать символом «|».
|Двигаемся влево, пока не дойдём до вертикальной стены.
нц пока слева свободно
влево
кц
|Двигаемся вверх, пока не дойдём до прохода в стене, и закрашиваем клетки.
нц пока не слева свободно
закрасить
вверх
кц
|Двигаемся дальше до вертикальной стены.
нц пока слева свободно
вверх
кц
|Двигаемся вверх до конца стены и закрашиваем клетки.
нц пока не слева свободно
закрасить
вверх
кц
|Обходим стену.
влево
вниз
|Двигаемся вниз, пока не дойдём до прохода в стене, и закрашиваем клетки.
нц пока не справа свободно
закрасить
вниз
кц
|Двигаемся дальше до вертикальной стены.
нц пока справа свободно
вниз
кц
|Двигаемся вниз до конца стены и закрашиваем клетки.
нц пока не справа свободно
закрасить
вниз
кц

Опубликовано: 09.04.2018 Обновлено: 17.04.2018
Поделись с друзьями

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

14 − 2 =