Решение 19 задания ОГЭ 2018 по информатике из демоверсии

Решение 19 задания ОГЭ 2018 по информатике из демонстрационного варианта. Проверяемые элементы содержания: Умение проводить обработку большого массива данных с использованием средств электронной таблицы или базы данных.

В электронную таблицу занесли данные о калорийности продуктов. Ниже приведены первые пять строк таблицы.

Решение 19 задания ОГЭ 2018 по информатике из демоверсии

В столбце A записан продукт; в столбце B – содержание в нём жиров; в столбце C – содержание белков; в столбце D – содержание углеводов и в столбце Е – калорийность этого продукта.

Всего в электронную таблицу были занесены данные по 1000 продуктам.

Выполните задание

Откройте файл с данной электронной таблицей (расположение файла Вам сообщат организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Сколько продуктов в таблице содержат меньше 50 г углеводов и меньше 50 г белков? Запишите число этих продуктов в ячейку H2 таблицы.

2. Какова средняя калорийность продуктов с содержанием жиров менее 1 г? Ответ на этот вопрос запишите в ячейку H3 таблицы с точностью не менее двух знаков после запятой.

Полученную таблицу необходимо сохранить под именем, указанным организаторами экзамена.

Решение 19 задания ОГЭ 2018 по информатике

Решение для OpenOffice.org Calc и для Microsoft Excel

Первая формула используется для русскоязычной записи функций; вторая – для англоязычной.

В ячейку F2 запишем формулу

=ЕСЛИ(И(D2<50;C2<50);1;0)
=IF(AND(D2<50;C2<50);1;0)

Скопируем формулу во все ячейки диапазона F3:F1001.

В ячейку H2 запишем формулу

=СУММ(F2:F1001)
=SUM(F2:F1001)

В ячейку H3 запишем формулу

=СУММЕСЛИ(B2:B1001; "<1";E2:E1001)/СЧЁТЕСЛИ(B2:B1001;"<1")
=SUMIF(B2:B1001; "<1";E2:E1001)/COUNTIF(B2:B1001;"<1")

Если задание выполнено правильно и при выполнении задания использовались файлы, специально подготовленные для проверки выполнения данного задания, то должны получиться следующие ответы:

на первый вопрос: 864;
на второй вопрос: 89,45

Опубликовано: 07.04.2018 Обновлено: 17.04.2018
Поделись с друзьями

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

четырнадцать − шесть =